• 子方有料致力于陪伴互联网运营小白共同探索成长,与IT爱好者共享探索乐趣
  • 淘·有料 | 爱购物爱省钱,天猫淘宝优惠天天有
  • 建站只为分享,欢迎在PC端文章面打赏支持
  • 使用Ctrl+D 可收藏本站

使用lnmp1.7新建站点配置SSL遇到Please refer xxx error code: 3报错

好玩有趣 陆子方 4个月前 (06-16) 303次浏览 1个评论 扫描二维码

SSL创建报错

子方准备新建一个站点,选择了Let’s Encrypt创建免费的SSL证书,遇到了以下错误提示

[Tue 09 Jun 2020 11:53:49 AM CST]  Please refer to https://curl.haxx.se/libcurl/c/libcurl-errors.html for error code: 3
[Tue 09 Jun 2020 11:53:49 AM CST] The new-authz request is ok.
[Tue 09 Jun 2020 11:53:49 AM CST] Error, can not get domain token entry crm.uliaos.org
[Tue 09 Jun 2020 11:53:49 AM CST] Please check log file for more details: /usr/local/acme.sh/acme.sh.log
Let's Encrypt SSL Certificate create failed!

错误分析

此前也遇到过类似的错误,主要的问题是Let’s Encrypt的证书更新方式经常变更, acme.sh 需要保持到最新的版本,这样才不容易出错。子方建议大家把acme.sh 设置为自动更新就好了

acme.sh自动更新

如果希望acme.sh保持自动更新,可以使用以下命令。更新后,子方就可以正常创建新的SSL证书了。

 acme.sh  --upgrade  --auto-upgrade

子方有料原创丨转载请注明原文链接
期待您的评论或捐赠,这是最好的鼓励和支持!
喜欢 (1)
[赞赏使我快乐]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到
(1)个小伙伴在吐槽
  1. 试了楼主的方法,依然报错:root@ip:~# acme.sh --upgrade --auto-upgrade[Wed Jul 29 10:55:01 CST 2020] Installing from online archive.[Wed Jul 29 10:55:01 CST 2020] Downloading https://github.com/Neilpang/acme.sh/archive/master.tar.gz[Wed Jul 29 10:55:01 CST 2020] Please refer to https://curl.haxx.se/libcurl/c/libcurl-errors.html for error code: 6[Wed Jul 29 10:55:01 CST 2020] Download error.[Wed Jul 29 10:55:01 CST 2020] Upgrade failed!
    匿名2020-07-29 10:53 回复