• 子方有料致力于陪伴互联网运营小白共同探索成长,与IT爱好者共享探索乐趣
  • 淘·有料 | 爱购物爱省钱,天猫淘宝优惠天天有
  • 建站只为分享,欢迎在PC端文章面打赏支持
  • 使用Ctrl+D 可收藏本站

LNMP一键包多PHP版本删除,安装后如何卸载不需要的PHP版本

好玩有趣 陆子方 1年前 (2019-08-16) 791次浏览 0个评论 扫描二维码

因为子方有个网站需要php5.6的环境,所以安装了多版本php

目前最新的稳定版本是php7.3,速度更快,子方推荐使用最新版的,这样更安全

来自子方的额外提醒

在lnmp1.6中,如果是在首次安装的是php5.6,然后再安装php7.3的话,在添加vhost的时候,是找不到php7.3的,只能手动添加

如果是先php5.6,然后再装php7.0,在添加时可以正常识别

也正是因为这样,子方推荐在首次安装时,选择php7.3作为默认主要的php运行环境

多PHP版本卸载

多php版本安装这里不多说,主要是说一下如何卸载。

子方使用是lnmp1.6版本,安装了php5.6php7.3

现需卸载php7.3,只需执行以下命令

(如需卸载其它版本,可以替换对应的版本号即可)

/etc/init.d/php-fpm7.3 stop

rm -rf /usr/local/php7.3

rm -f /etc/init.d/php-fpm7.3lnmp

rm -f /usr/local/nginx/conf/enable-php7.3.conf

最后,执行重启lnmp restart


子方有料原创丨转载请注明原文链接
期待您的评论或捐赠,这是最好的鼓励和支持!
喜欢 (0)
[赞赏使我快乐]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到